操盘手股票网-股票学习论坛

欢迎光临操盘手股票网
客服QQ:293560092
 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
股票配资
博弈量能
量价九式
查看: 379|回复: 0

[通达信] 通达信喊止跌主图指标

[复制链接]

1382

主题

6015

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
16594
发表于 2018-9-1 12:57:47 | 显示全部楼层 |阅读模式
指标公式
技术类别: 选股公式 
此主图是本人自用多年的主图指标,绝对极品,指标非常精确而且不带未来,指标有精确的买卖点提示,最重要的是有超底信号,和拉升信号,这样对我们炒作个股是非常方便的,还有个股仓位控制等等,绝对是百年不遇的好指标!


CCRAWTEXT_FIX(CURRBARSCOUNT=60,0.02,0.11,0,'【小飞】'),COLORRED;

M60:=MA(C,60);
M120:=MA(C,120);
DRAWBAND(M60,RGB(90,0,0),M120,RGB(0,90,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
LC11:=REF(CLOSE,1);
RSI11:=((SMA(MAX((CLOSE - LC11),0),3,1) / SMA(ABS((CLOSE - LC11)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一0.809:REFDATE(H1,DATE),DOTLINE,COLORYELLOW;
二0.618:REFDATE(H2,DATE),DOTLINE,COLORMAGENTA;
三0.500:REFDATE(H3,DATE),DOTLINE,COLORWHITE;
四0.382:REFDATE(H4,DATE),DOTLINE,COLORGREEN;
五0.191:REFDATE(H5,DATE),DOTLINE,COLORYELLOW;
低:REFDATE(低1,DATE),DOTLINE,COLORRED;
收盘破红必跑2:MA(CLOSE,7)CROSSDOT,COLORLIRED;
CG:MA((LOW+HIGH+CLOSE*2)/4,10);
FL:HHV(CG,3),COLORGREEN,POINTDOT;
FS:IF(CG<FL,(CG-(FL-CG)),FL),COLORGREEN,;
FL1:HHV(CG,5),COLORGREEN,POINTDOT;
FS1:IF(CG<FL1,(CG-(FL1-CG)),FL1),COLORGREEN,;
FL2:HHV(CG,7),COLORGREEN,POINTDOT;
FS2:IF(CG<FL2,(CG-(FL2-CG)),FL2),COLORGREEN,;
FL3:HHV(CG,9),COLORFFABA3,LINETHICK2;
FS3:IF(CG<FL3,(CG-(FL3-CG)),FL3),COLORFFABA3,LINETHICK2;
ZLZC1:=(HHV(H,144)-((HHV(H,144)-LLV(L,144))*0.618)),POINTDOT,LINETHICK2;
ZLZC2:=(HHV(H,144)-((HHV(H,144)-LLV(L,144))*0.5)),POINTDOT,LINETHICK2;
ZLZC3:=(HHV(H,144)-((HHV(H,144)-LLV(L,144))*0.382));
POLYLINEFS3>MA(FS3,5),FS3),COLOR1010F1,LINETHICK2;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买=1,5),LOW-0.03,'*喊拉升'),COLORLIMAGENTA;
AA11:=MA(C,5);
BB11:=MA(C,15);
A:=CROSS(AA11,BB11);
B:=CROSS(收盘破红必跑2,AA11) AND CC;
STICKLINE(A,LLV(L,4),LLV(L,4),2,3),COLORLIBLUE;
DRAWTEXT(A,LLV(L,4),'喊止跌抄底啦') AND CC,COLORGREEN;
STICKLINE(B,HHV(H,4),HHV(H,4),5,3),COLORYELLOW;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
TT:=240/FROMOPEN;
比:=TT;
促进指数MFL:=(HIGH-LOW)*1000000/(VOL*比),COLORRED;
AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);
AZ2:=EMA(AY2,9);
LT2:=(AY2-AZ2);
L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;
ZGD:=HHV(H,80)*0.99;
ZGD2:=CONST(ZGD);
ZDD:=LLV(L211,80);
ZDD2:=CONST(ZDD);
YYA4:=MA(CLOSE,20);
YYA5:=(CLOSE > MA(CLOSE,5));
YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));
YYA7:=(CLOSE > MA(CLOSE,10));
YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));
YYA9:=(CLOSE > MA(CLOSE,20));
YYA10:=REF(YYA4,1);
YYA11:=(YYA4 > YYA10);
YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,10);
J1:=CONST(IF( YYAVX > 0,200,100)) AND CC;
J2:=CONST(IF( YYAVX > 0,00,100)) AND CC;
J3:=CONST(IF( YYAVX > 0,100,100)) AND CC;
ZGD3:=ZGD2;
ZDD3:=ZDD2;
ZGD4:=ZGD2;
情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));
情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));
情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;
情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));
大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));
大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));
大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));
大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));
大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));
大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));
大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));
MFI:=(HIGH-LOW)*1000000/(VOL*比);
绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);
MMM1:=CONST(绿灯);
衰退:=MFI<REF(MFI,1)AND VOL*比<REF(VOL,1);
MMM2:=CONST(衰退);
伪装:=MFI>=REF(MFI,1)AND VOL*比<REF(VOL,1);
MMM3:=CONST(伪装);
蛰伏:=MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1);
MMM4:=CONST(蛰伏);
TS1:=IF(情况1=1,0.06+0.06,0.06);
TS2:=IF(情况2=1,TS1+0.18,TS1);
TS3:=IF(情况3=1,TS2+0.18,TS2);
TS4:=IF(情况4=1,TS3+0.18,TS3);
TS5:=IF(情况5=1,TS4+0.18,TS4);
TS6:=IF(情况6=1,TS5+0.18,TS5);
TS7:=IF(情况7=1,TS6+0.18,TS6);
TS8:=IF(情况8=1,TS7+0.18,TS7);
TS9:=IF(情况9=1,TS8+0.18,TS8);
TS10:=IF(情况10=1,TS9+0.18,TS9);
TS11:=IF(情况11=1,TS10+0.18,TS10);
TS12:=IF(情况12=1,TS11+0.18,TS11);
TS13:=IF(情况13=1,TS12+0.18,TS12);
TS14:=IF(情况14=1,TS13+0.18,TS13);
TS15:=IF(情况15=1,TS14+0.18,TS14);
TS16:=IF(情况16=1,TS15+0.18,TS15);
TS17:=IF(大盘1=1,TS16+0.18,TS16);
TS18:=IF(大盘2=1,TS17+0.18,TS17);
TS19:=IF(大盘3=1,TS18+0.18,TS18);
TS20:=IF(大盘4=1,TS19+0.18,TS19);
TS21:=IF(大盘5=1,TS20+0.18,TS20);
TS22:=IF(大盘6=1,TS21+0.18,TS21);
TS23:=IF(大盘7=1,TS22+0.18,TS22);
TS24:=IF(大盘8=1,TS23+0.18,TS23);
TS25:=IF(MMM1=1,TS24+0.18,TS24);
TS26:=IF(MMM2=1,TS25+0.18,TS25);
TS27:=IF(MMM3=1,TS26+0.18,TS26);
TS28:=IF(MMM4=1,TS27+0.18,TS27);
DRAWTEXT_FIX(情况1=1 ,0.06,TS1,0,'量能理想,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF;
DRAWTEXT_FIX(情况2=1 ,0.06,TS2,0,'走势趋强量能不足,短线进场,仓位在1/2左右'),COLORFF00FF;
DRAWTEXT_FIX(情况3=1 ,0.06,TS3,0,'量价良好,并没有明显走强,短线进场,仓位1/2左右。'),COLORFF00FF;
DRAWTEXT_FIX(情况4=1 ,0.06,TS4,0,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右。'),COLORFF00FF;
DRAWTEXT_FIX(情况5=1 ,0.06,TS5,0,'形态变坏,走势尚可,重仓减大半,清仓者观望。'),COLOR00FFFF;
DRAWTEXT_FIX(情况6=1 ,0.06,TS6,0,'随大盘一起下跌,明显缩量走势,考虑大盘风险,减持或清仓。'),COLOR00FFFF;
DRAWTEXT_FIX(情况7=1 ,0.06,TS7,0,'该股放量下跌,走势明显偏弱,离场观望。') AND CC,COLORFFFFFF;
DRAWTEXT_FIX(情况8=1 ,0.06,TS8,0,'该股缩量下跌,走势偏弱,离场观望。') AND CC,COLORFFFF00;
DRAWTEXT_FIX(情况9=1 ,0.06,TS9,0,'该股形态良好,强势明显,量能充足,可以继续持有。') AND CC,COLOR00FFFF;
DRAWTEXT_FIX(情况10=1,0.06,TS10,0,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险') AND CC,COLOR00FFFF;
DRAWTEXT_FIX(情况11=1,0.06,TS11,0,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。') AND CC,COLORFFFFFF;
DRAWTEXT_FIX(情况12=1,0.06,TS12,0,'该股走势趋弱,量能不足,减持大部分筹码') AND CC,COLORFFFF00;
DRAWTEXT_FIX(情况13=1,0.06,TS13,0,'该股形态不佳,注意成交量的变化,但目前不适合参与。') AND CC,COLORFFFF00;

DRAWTEXT_FIX(情况14=1,0.06,TS14,0,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。');
DRAWTEXT_FIX(情况15=1,0.06,TS15,0,'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORFFFF00;
DRAWTEXT_FIX(情况16=1,0.06,TS16,0,'该股走势太弱,没有参与价值。'),COLORFFFFFF;
DRAWTEXT_FIX(大盘1,0.06,TS17,0,'总势量能理想,2/3仓位, 前一轮下跌,是否最佳买点,否则谨慎介入。'),COLOR00FF00;
DRAWTEXT_FIX(大盘2,0.06,TS18,0,'总势趋强,量能不足,若前一轮下跌,短线进场1/2,量能放大加仓。'),COLORFF00FF;
DRAWTEXT_FIX(大盘3,0.06,TS19,0,'总势形态走坏,重仓者可以减去大部分仓位。'),COLORAAAAAA;
DRAWTEXT_FIX(大盘4,0.06,TS20,0,'总势缩量调整,注意风险,短线清仓观望。'),COLORFFFFFF;
DRAWTEXT_FIX(大盘5,0.06,TS21,0,'总势走势良好,量能理想,可以继续持有强势股。'),COLOR00FFFF;
DRAWTEXT_FIX(大盘6,0.06,TS22,0,'总势形态良好,但量能稍显不足,随时准备减仓'),COLOR00FF00;
DRAWTEXT_FIX(大盘7,0.06,TS23,0,'总势趋势不明,注意成交量变化,目前不适宜进场。'),COLORFFFFFF;
DRAWTEXT_FIX(大盘8,0.06,TS24,0,'总势趋势向下,量能萎缩,不适合进场。'),COLORFFFFFF;
DRAWTEXT_FIX(MMM1,0.06,TS25,0,'[绿灯]实计交易量增加。MFI促进指数增加。'),COLORFFFFFF;
DRAWTEXT_FIX(MMM2,0.06,TS26,0,'[衰退]实计交易量减少。MFI促进指数减少。'),COLORGREEN;
DRAWTEXT_FIX(MMM3,0.06,TS27,0,'[伪装]实计交易量减少。MFI促进指数增加。'),COLORGREEN;
DRAWTEXT_FIX(MMM4,0.06,TS28,0,'[蛰伏]实计交易量增加。MFI促进指数减少。'),COLORYELLOW;
VAR8Q:=(2*CLOSE+HIGH+LOW)/4;
VAR9Q:=EXPMA(EXPMA(EXPMA(VAR8Q,2),3),3);
J:=(VAR9Q-REF(VAR9Q,1))*100, COLORSTICK;
D1:=SMA(J,3,1);
KX:=SMA(J,2,1);
A11:=EMA(CLOSE,2),COLORWHITE;
A21:=EMA(CLOSE,5);
N1:=3;M1:=13;M11:=5;M21:=5;
A31:=EMA(CLOSE,12);
A41:=EMA(CLOSE,25);
B1:=A11>REF(A11,1);
S:=A11<REF(A11,1)AND REF(A11,1)>REF(A11,2);
STICKLINE(B1,H,L,0,0),COLORYELLOW;
STICKLINE(B1,O,C,-1,0),COLOR6633EE;
STICKLINE(B1,O,C,2.7,0),COLOR3666EE;
STICKLINE(B1,O,C,2.1,0),COLOR2299EE;
STICKLINE(B1,O,C,1.4,0),COLOR11AAEF;
STICKLINE(B1,O,C,0.8,0),COLOR00BBFE;
STICKLINE(B1,O,C,0.4,0),COLOR00CCFE;
STICKLINE(B1,O,C,0.24,0),COLOR00DDFF;
STICKLINE(B1,O,C,0.1,0),COLOR00EEFF;
STICKLINE(B1,O,C,0.05,0),COLOR00FFFF;
DRAWICON(A11>REF(A11,1)AND REF(A11,1)<REF(A11,2),L,1);
DRAWICON(S,H,2);









本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
所有内容均来自于互联网,本站不提供资源存储;链接内容仅用于学习交流,如有侵权,请邮件告知,确认后将第一时间删除。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

      欢迎光临操盘手股票网,本站内容只作交流和学习之用。特别注意: 1、为了保证用户质量,需10元购买邀请码注册才能发贴。2、部分主题需要相关阅读权限,通过发贴和回复挣积分或充值获取积分;某些主题需要付费才能阅读,点导航栏上的 “积分充值”。按说明用支付宝充值。 3、如有技术、版权及其它法律法规方面问题,请联系管理员QQ:293560092

Archiver|小黑屋|手机版|操盘手股票网

Copyright © 2001-2013 Comsenz Inc.Template by lps6All Rights Reserved.

Powered by lps6!X3.4( 苏ICP备10047389号-1 )QQ