操盘手股票网-股票学习论坛

搜索
亿配资
赤盈配资
鑫配资
联美
涵星长
魔法K线——王焕昌
股尊胜术——蔡宗园
镜射理论——钟黎融
孔明线——毛鹏皓
量价宗师——林新象
金钱相对论——蔡正华
美丽学——彭明允
熊狮战法——汪海华
BDK战法——张清华
独孤九剑——刘俊荣
伯乐指标——陈威伯
坦克爷——孙伊廷
太极战法——曾光辉
布林大师——董钟祥
股市生命力——罗威
K线理论——黄勤翔
优酷去除头部广告
K线应用视频讲解
低位单峰密集突破
移动平均线的应用
量价关系应用讲解
突破颈线位技术应用
点击上传展示内容
点击上传展示内容
查看: 283|回复: 0
收起左侧

[主图指标] [通达信] 通达信龙轩主图指标公式贴图源码

[复制链接]

1565

主题

6274

帖子

216

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
216
发表于 2019-7-30 19:56:09 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
【资料名称】:【指标】2017年最新通达信版本量学主图指标公式赠送专用量柱MACD指标
【资料描述】:
****此区域为收费内容****    需支付 10 盘币后可查看立即购买


0.jpg 1.jpg 2.jpg 3.jpg 4.jpg


【下载地址】:
  1. {公式名称: 龙轩主图V6版  WACG.TAOBAO.COM}
  2. 上涨家数:"SZ399002$ADVANCE"+"SH999999$ADVANCE"-"SZ399108$ADVANCE",COLORRED,NODRAW;{仅限於日线周期}
  3. 下跌家数:"SZ399002$DECLINE"+"SH999999$DECLINE"-"SZ399108$DECLINE",COLORGREEN,NODRAW;
  4. 涨跌比:上涨家数/(上涨家数+下跌家数)*100,NODRAW,COLORWHITE;
  5. Z1:=STRCAT(HYBLOCK,' ');
  6. Z2:=STRCAT(Z1,DYBLOCK);
  7. Z3:=STRCAT(Z2,' ');
  8. DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORWHITE;
  9. HJ_1:=CLOSE/REF(CLOSE,1)>1.097;
  10. 年涨停:COUNT(HJ_1,250),NODRAW,COLORLIMAGENTA;
  11. HJ_2:=0.01;{WWW.88GS.COM}
  12. HJ_3:=IF(精准线=1,LOW,IF(精准线=2,OPEN,IF(精准线=3,CLOSE,HIGH)));
  13. 精准值:CONST(HJ_3),DOTLINE,COLORWHITE;
  14. HJ_4:=COUNT(ABS(LOW-精准值)<=HJ_2,120)-1;
  15. HJ_5:=COUNT(ABS(HIGH-精准值)<=HJ_2,120)-1;
  16. HJ_6:=COUNT(ABS(CLOSE-精准值)<=HJ_2,120)-1;
  17. HJ_7:=COUNT(ABS(OPEN-精准值)<=HJ_2,120)-1;
  18. 精准数:HJ_4+HJ_5+HJ_6+HJ_7+3,NODRAW,COLORGREEN;
  19. DRAWICON(ABS(LOW-精准值)<=HJ_2,精准值*0.98,11);
  20. DRAWICON(ABS(HIGH-精准值)<=HJ_2,精准值*1.02,12);
  21. DRAWICON(ABS(OPEN-精准值)<=HJ_2,精准值*1.02,12);
  22. DRAWICON(ABS(CLOSE-精准值)<=HJ_2,精准值*1.02,12);
  23. 上三一:(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))*2/3+MIN(OPEN,CLOSE),NODRAW,COLORMAGENTA;
  24. 二一位:(OPEN+CLOSE)/2,NODRAW,COLORRED;
  25. 下三一:(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))/3+MIN(OPEN,CLOSE),NODRAW,COLORYELLOW;
  26. 虚三一:=HIGH-(HIGH-LOW)*0.333,NODRAW;
  27. 虚二一:HIGH-(HIGH-LOW)*0.5,NODRAW;
  28. 虚三二:=HIGH-(HIGH-LOW)*0.666,NODRAW,COLOR8000FF;
  29. HJ_8:=MA(CLOSE,3);
  30. HJ_9:=REFX(HJ_8,3);
  31. 小东西:=VOL/REF(VOL,1)>=1.9 AND CLOSE>REF(CLOSE,1),NODRAW,COLORYELLOW;
  32. STICKLINE(小东西,HIGH,LOW,0,0),COLORYELLOW;
  33. STICKLINE(小东西,OPEN,CLOSE,3.1,3),COLORYELLOW;
  34. 高于实顶:=CLOSE<HJ_9,NODRAW;
  35. HJ_10:=OPEN<REFX(CLOSE,1) AND OPEN<REFX(CLOSE,2) AND OPEN<REFX(CLOSE,2);
  36. HJ_11:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>2;
  37. HJ_12:=CLOSE=OPEN AND CLOSE=HIGH AND CLOSE=LOW;
  38. HJ_13:=高于实顶 AND HJ_10 AND HJ_11 AND HJ_12=0;
  39. STICKLINE(REF(LOW,1)>HIGH,HIGH,REF(LOW,1),5,0),COLORGRAY;
  40. STICKLINE(REF(HIGH,1)<LOW,LOW,REF(HIGH,1),5,0),COLORGRAY;
  41. DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
  42. HJ_14:=REF(CLOSE,1);
  43. HJ_15:=IF(CLOSE>=1,10000,100000);
  44. HJ_16:=1.1*HJ_14-49/HJ_15;
  45. HJ_17:=1.05*HJ_14-49/HJ_15;
  46. HJ_18:=0.9*HJ_14+51/HJ_15;
  47. HJ_19:=0.95*HJ_14+51/HJ_15;
  48. HJ_20:=NAMELIKE(3) OR NAMELIKE(4);
  49. HJ_21:=IF(HJ_20,CLOSE>=HJ_17,CLOSE>=HJ_16);
  50. HJ_22:=IF(HJ_20,CLOSE<=HJ_19,CLOSE<=HJ_18);
  51. HJ_23:=IF(HJ_20,HIGH>=HJ_17,HIGH>=HJ_16);
  52. HJ_24:=IF(HJ_20,LOW<=HJ_19,LOW<=HJ_18);
  53. STICKLINE(HJ_23,HIGH,MAX(CLOSE,OPEN),0,0),COLORMAGENTA;
  54. STICKLINE(HJ_24,LOW,MIN(CLOSE,OPEN),0,0),COLORLICYAN;
  55. HJ_25:=CLOSE>OPEN AND (CLOSE>=HJ_17 OR CLOSE>1.05*OPEN-51/HJ_15) OR (CLOSE>1000 AND CLOSE>HJ_14*1.024);
  56. STICKLINE(HJ_25,OPEN,CLOSE,1,0),COLOR0000BB;
  57. HJ_26:=CLOSE<OPEN AND (CLOSE<=HJ_19 OR CLOSE<0.95*OPEN+49/HJ_15) OR (CLOSE>1000 AND CLOSE<HJ_14*0.976);
  58. STICKLINE(HJ_26,OPEN,CLOSE,1,0),COLORLIGREEN;
  59. STICKLINE(HJ_21,OPEN,CLOSE,1,0),COLORMAGENTA;
  60. STICKLINE(HJ_22,OPEN,CLOSE,1,0),COLORLICYAN;
  61. STICKLINE(HJ_13,OPEN*1.01,CLOSE*0.99,0,0),COLORWHITE;
  62. HJ_27:=PERIOD=5 AND NAMELIKE(5) AND (ABS(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.025 OR ABS(CLOSE-OPEN)>=60);
  63. STICKLINE(HJ_27,(HIGH+LOW)/2,(HIGH+LOW)/2,2,0),COLORYELLOW;
  64. STICKLINE(HJ_25 OR HJ_26 OR HJ_21 OR HJ_22 AND BETWEEN(CLOSE,1,500),LOW+(HIGH-LOW)/2,LOW+(HIGH-LOW)/2,1,0),COLORYELLOW;
  65. STICKLINE(HJ_25 OR HJ_26 OR HJ_21 OR HJ_22 AND BETWEEN(CLOSE,1,500),二一位,二一位,1,0),COLORBLUE;
  66. 均价:=AMOUNT/VOL/100;
  67. 假阳:=C>O AND REF(C,1)>均价 AND C>均价 AND C<300 ;
  68. STICKLINE(假阳,O,C,1,0)COLORGREEN;
  69. 假阴:=O>C AND C<均价  AND  均价>REF(C,1) ;
  70. STICKLINE(假阴,O,C,1,0),COLORRED;
  71. TJ:=C<O;{WWW.88GS.COM}
  72. 显性假阴:=C>REF(C,1) AND TJ;
  73. 隐性假阴:=AMOUNT/V/100>REF(C,1) AND O>REF(C,1) AND NOT(显性假阴) AND TJ;
  74. STICKLINE(显性假阴,O,C,1,0),COLORRED;
  75. 比系数:=1.3;
  76. 金线:=1;
  77. 临界点:=0;
  78. MA5:=MA(C,5);
  79. MA10:=MA(C,10);
  80. MA20:=MA(C,20);
  81. 均线:=MA5>REF(MA5,1) AND MA10<REF(MA10,1) AND MA20<REF(MA20,1);
  82. RV1:=REF(V,1);
  83. RV2:=REF(V,2);
  84. RV3:=REF(V,3);
  85. RC1:=REF(C,1);
  86. RC2:=REF(C,2);
  87. RC3:=REF(C,3);
  88. RC4:=REF(C,4);
  89. RO1:=REF(O,1);
  90. RO2:=REF(O,2);
  91. RO3:=REF(O,3);
  92. RO4:=REF(O,4);
  93. 不破价顶:=C>=RC3 AND RC1>=RC3 AND RC2>=RC3;
  94. 不破价底:=L>RO3 AND REF(L,1)>RO3 AND REF(L,2)>RO3;
  95. 均价1:=AMOUNT/VOL/100;
  96. RJ1:=REF(均价1,1);
  97. RJ2:=REF(均价1,2);
  98. 阳柱:=C>=O OR (C<O AND 均价1>RC1);
  99. 三日二阳:=COUNT(阳柱,3)>=2;
  100. 基价柱阳:=RC3>RO3;
  101. 价渐升:=(均价1>=RJ1 OR C>RC1) AND (RJ1>=RJ2 OR RC1>=RC2);
  102. 均价升:=(C+RC1+RC2)/3>RC3;
  103. 量渐升:=V>RV1 AND RV1>RV2 ;
  104. 量渐减:=V<=RV1 AND RV1<=RV2 ;
  105. 均量减:=(V+RV1+RV2)/3<=RV3 AND NOT(量渐升);
  106. 日价量比:=C/V;
  107. 日价量比升:=日价量比>=REF(日价量比,1) AND REF(日价量比,1)>=REF(日价量比,2);
  108. 均价升幅:=(C+RC1+RC2)/3/RC3;
  109. 均量升幅:=(V+RV1+RV2)/3/RV3;
  110. 价量比:=比系数*均价升幅/均量升幅>1;
  111. 基前跳空:=RO3>RC4 AND RC4>RO4;
  112. 黄金柱1T:=基价柱阳 AND 价渐升 AND 量渐减 AND 不破价顶 AND 不破价底 AND 基前跳空;
  113.     BACKSET101T:=BACKSET(黄金柱1T,5);
  114.     FILTER101T:=FILTER(BACKSET101T,4);
  115. 黄金柱1:=基价柱阳 AND 价渐升 AND 量渐减 AND 不破价顶 AND 不破价底 ;
  116.     BACKSET101:=BACKSET(黄金柱1,4);
  117.     FILTER101:=FILTER(BACKSET101,3);
  118. 黄金柱11:=黄金柱1 AND REF(黄金柱1,1);
  119.     BACKSET1011:=BACKSET(黄金柱11,4);
  120.     FILTER1011:=FILTER(BACKSET1011,3);
  121. 黄金柱12:=黄金柱1 AND REF(黄金柱1,2);
  122.     BACKSET1012:=BACKSET(黄金柱12,4);
  123.     FILTER1012:=FILTER(BACKSET1012,3);
  124. 黄金柱13:=黄金柱1 AND REF(黄金柱1,3);
  125.     BACKSET1013:=BACKSET(黄金柱13,4);
  126.     FILTER1013:=FILTER(BACKSET1013,3);
  127. 黄金柱2T:=基价柱阳 AND 价渐升 AND 均量减 AND NOT(量渐升) AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱1T);
  128.     BACKSET201T:=BACKSET(黄金柱2T,5);
  129.     FILTER201T:=FILTER(BACKSET201T,4);
  130. 黄金柱2:=基价柱阳 AND 价渐升 AND 均量减 AND NOT(量渐升) AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱1T);
  131.     BACKSET201:=BACKSET(黄金柱2,4);
  132.     FILTER201:=FILTER(BACKSET201,3);
  133. 黄金柱21:=黄金柱2 AND REF(黄金柱2,1);
  134.     BACKSET2011:=BACKSET(黄金柱21,4);
  135.     FILTER2011:=FILTER(BACKSET2011,3);
  136. 黄金柱22:=黄金柱2 AND REF(黄金柱2,2);
  137.     BACKSET2012:=BACKSET(黄金柱22,4);
  138.     FILTER2012:=FILTER(BACKSET2012,3);
  139. 黄金柱23:=黄金柱2 AND REF(黄金柱2,3);
  140.     BACKSET2013:=BACKSET(黄金柱23,4);
  141.     FILTER2013:=FILTER(BACKSET2013,3);
  142. 黄金柱3T:=基价柱阳  AND 均价升 AND 量渐减 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱1T)  AND NOT(黄金柱2T);
  143.     BACKSET301T:=BACKSET(黄金柱3T,5);
  144.     FILTER301T:=FILTER(BACKSET301T,4);
  145. 黄金柱3:=基价柱阳  AND 均价升 AND 量渐减 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱1T) AND NOT(黄金柱2T);
  146.     BACKSET301:=BACKSET(黄金柱3,4);
  147.     FILTER301:=FILTER(BACKSET301,3);
  148. 黄金柱31:=黄金柱3 AND REF(黄金柱3,1);
  149.     BACKSET3011:=BACKSET(黄金柱31,4);
  150.     FILTER3011:=FILTER(BACKSET3011,3);
  151. 黄金柱32:=黄金柱3 AND REF(黄金柱3,2);
  152.     BACKSET3012:=BACKSET(黄金柱32,4);
  153.     FILTER3012:=FILTER(BACKSET3012,3);
  154. 黄金柱33:=黄金柱3 AND REF(黄金柱3,3);
  155.     BACKSET3013:=BACKSET(黄金柱33,4);
  156.     FILTER3013:=FILTER(BACKSET3013,3);
  157. 黄金柱4T:=基价柱阳  AND 均价升 AND 均量减 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱1T) AND NOT(黄金柱2) AND NOT(黄金柱2T) AND NOT(黄金柱3) AND NOT(黄金柱3T);
  158.     BACKSET401T:=BACKSET(黄金柱4T,5);
  159.     FILTER401T:=FILTER(BACKSET401T,4);
  160. 黄金柱4:=基价柱阳  AND 均价升 AND 均量减 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T);
  161.     BACKSET401:=BACKSET(黄金柱4,4);
  162.     FILTER401:=FILTER(BACKSET401,3);
  163. 黄金柱41:=黄金柱4 AND REF(黄金柱4,1);
  164.     BACKSET4011:=BACKSET(黄金柱41,4);
  165.     FILTER4011:=FILTER(BACKSET4011,3);
  166. 黄金柱42:=黄金柱4 AND REF(黄金柱4,2);
  167.     BACKSET4012:=BACKSET(黄金柱42,4);
  168.     FILTER4012:=FILTER(BACKSET4012,3);
  169. 黄金柱43:=黄金柱4 AND REF(黄金柱4,3);
  170.     BACKSET4013:=BACKSET(黄金柱43,4);
  171.     FILTER4013:=FILTER(BACKSET4013,3);
  172. 黄金柱5T:=基价柱阳  AND 均价升 AND 价量比 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱1T)   AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T);
  173.     BACKSET501T:=BACKSET(黄金柱5T,5);
  174.     FILTER501T:=FILTER(BACKSET501T,4);
  175. 黄金柱5:=基价柱阳  AND 均价升 AND 价量比 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱1T)   AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T);
  176.     BACKSET501:=BACKSET(黄金柱5,4);
  177.     FILTER501:=FILTER(BACKSET501,3);
  178. 黄金柱51:=黄金柱5 AND REF(黄金柱5,1);
  179.     BACKSET5011:=BACKSET(黄金柱51,4);
  180.     FILTER5011:=FILTER(BACKSET5011,3);
  181. 黄金柱52:=黄金柱5 AND REF(黄金柱5,2);
  182.     BACKSET5012:=BACKSET(黄金柱52,4);
  183.     FILTER5012:=FILTER(BACKSET5012,3);
  184. 黄金柱53:=黄金柱5 AND REF(黄金柱5,3);
  185.     BACKSET5013:=BACKSET(黄金柱53,4);
  186.     FILTER5013:=FILTER(BACKSET5013,3);
  187. 黄金柱6T:=基价柱阳  AND 均价升 AND 日价量比升 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱5) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T) AND NOT(黄金柱5T);
  188.     BACKSET601T:=BACKSET(黄金柱6T,5);
  189.     FILTER601T:=FILTER(BACKSET601T,4);
  190. 黄金柱6:=基价柱阳  AND 均价升 AND 日价量比升 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱5) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T) AND NOT(黄金柱5T);
  191.     BACKSET601:=BACKSET(黄金柱6,4);
  192.     FILTER601:=FILTER(BACKSET601,3);
  193. 黄金柱61:=黄金柱6 AND REF(黄金柱6,1);
  194.     BACKSET6011:=BACKSET(黄金柱61,4);
  195.     FILTER6011:=FILTER(BACKSET6011,3);
  196. 黄金柱62:=黄金柱6 AND REF(黄金柱6,2);
  197.     BACKSET6012:=BACKSET(黄金柱62,4);
  198.     FILTER6012:=FILTER(BACKSET6012,3);
  199. 黄金柱63:=黄金柱6 AND REF(黄金柱6,3);
  200.     BACKSET6013:=BACKSET(黄金柱63,4);
  201.     FILTER6013:=FILTER(BACKSET6013,3);
  202. FIL1:=(FILTER101 AND NOT(REF(FILTER101,4))) OR (FILTER1011 AND NOT(REF(FILTER1011,4))) OR (FILTER1012 AND NOT(REF(FILTER1012,4))) OR (FILTER1013 AND NOT(REF(FILTER1013,4)));
  203. FIL2:=(FILTER201 AND NOT(REF(FILTER201,4))) OR (FILTER2011 AND NOT(REF(FILTER2011,4))) OR (FILTER2012 AND NOT(REF(FILTER2012,4))) OR (FILTER2013 AND NOT(REF(FILTER2013,4)));
  204. FIL3:=(FILTER301 AND NOT(REF(FILTER301,4))) OR (FILTER3011 AND NOT(REF(FILTER3011,4))) OR (FILTER3012 AND NOT(REF(FILTER3012,4))) OR (FILTER3013 AND NOT(REF(FILTER3013,4)));
  205. FIL4:=(FILTER401 AND NOT(REF(FILTER401,4))) OR (FILTER4011 AND NOT(REF(FILTER4011,4))) OR (FILTER4012 AND NOT(REF(FILTER4012,4))) OR (FILTER4013 AND NOT(REF(FILTER4013,4)));
  206. FIL5:=(FILTER501 AND NOT(REF(FILTER501,4))) OR (FILTER5011 AND NOT(REF(FILTER5011,4))) OR (FILTER5012 AND NOT(REF(FILTER5012,4))) OR (FILTER5013 AND NOT(REF(FILTER5013,4)));
  207. FIL6:=(FILTER601 AND NOT(REF(FILTER601,4))) OR (FILTER6011 AND NOT(REF(FILTER6011,4))) OR (FILTER6012 AND NOT(REF(FILTER6012,4))) OR (FILTER6013 AND NOT(REF(FILTER6013,4)));
  208. FIL:=FIL1 OR FIL2 OR FIL3 OR FIL4 OR FIL5 OR FIL6;
  209. STICKLINE(FIL AND NOT(REF(FIL,4)),OPEN,CLOSE,1,0),COLOR0099FF;
  210. DRAWTEXT(文字开关>0 AND FIL AND NOT(REF(FIL,4)),LOW*0.988,'↖金'),COLORYELLOW;
  211. K1:=SUMBARS(FIL,1);
  212. STICKLINE(黄金线开关>0 AND K1 AND 金线=1,REF(CLOSE,K1-1),REF(CLOSE,K1-1),10,0),COLORAA00FF;
  213. STICKLINE(黄金线开关>0 AND K1 AND 金线=1,REF(LOW,K1-1),REF(LOW,K1-1),10,0),COLORYELLOW;
  214. FIL1T:=(FILTER101T AND NOT(REF(FILTER101T,5)));
  215. FIL2T:=(FILTER201T AND NOT(REF(FILTER201T,5)));
  216. FIL3T:=(FILTER301T AND NOT(REF(FILTER301T,5)));
  217. FIL4T:=(FILTER401T AND NOT(REF(FILTER401T,5)));
  218. FIL5T:=(FILTER501T AND NOT(REF(FILTER501T,5)));
  219. FIL6T:=(FILTER601T AND NOT(REF(FILTER601T,5)));
  220. FILT:=FIL1T OR FIL2T OR FIL3T OR FIL4T OR FIL5T OR FIL6T;
  221. STICKLINE(FILT AND NOT(REF(FILT,5)),OPEN,CLOSE,1,0),COLOR0000FF;
  222. DRAWTEXT(文字开关>0 AND FILT AND NOT(REF(FILT,5)),LOW*0.975,'↖帅'),COLORRED;
  223. K2:=SUMBARS(FILT,1);

  224. 黄金柱LJ:=(黄金柱1 OR 黄金柱2 OR 黄金柱3 OR 黄金柱4 OR 黄金柱5  OR 黄金柱6 ) AND 均线  AND 临界点;
  225.     BACKSET10LJ:=BACKSET(黄金柱LJ ,4);
  226.     FILTER10LJ:=FILTER(BACKSET10LJ,3);
  227.     STICKLINE(FILTER10LJ AND NOT(REF(FILTER10LJ,4)),OPEN,CLOSE,1,0),COLOR0099FF;
  228. 黄金柱LJT:=(黄金柱1T OR 黄金柱2T OR 黄金柱3T OR 黄金柱4T OR 黄金柱5T OR 黄金柱6T) AND 均线 AND 临界点 ;
  229.     BACKSET10LJT:=BACKSET(黄金柱LJT ,5);
  230.     FILTER10LJT:=FILTER(BACKSET10LJT,5);
  231.     STICKLINE(FILTER10LJT AND NOT(REF(FILTER10LJT,4)),OPEN,CLOSE,1,0),COLOR0099FF;
  232. 定义黄金柱:=黄金柱1 OR 黄金柱2 OR 黄金柱3 OR 黄金柱4 OR 黄金柱5
  233. OR 黄金柱6  AND  NOT(DYNAINFO(4)=0)   AND C=HHV(C,3);   
  234. 阴元帅柱:=定义黄金柱  AND REF(C,4)<REF(C,5) AND  REF(C,4)< REF(O,4)  AND  REF(O,3)>=REF(O,4);   
  235. YY:=FILTER(BACKSET(阴元帅柱 ,5),5);
  236. {STICKLINE(YY,L,H,0.5,0),COLORWHITE;}
  237. DRAWTEXT(文字开关>0 AND YY,LOW*0.988,'↖阴帅'),COLORFFFF00;
  238. JY_01:=VALUEWHEN(K1 AND 金线=1,REF(CLOSE,K1-1));
  239. JY_02:=VALUEWHEN(K1 AND 金线=1,REF(LOW,K1-1));
  240. JY_03:=CLOSE<OPEN AND CLOSE>JY_01 AND OPEN<JY_01;
  241. JY_04:=CLOSE<OPEN AND CLOSE>JY_02 AND OPEN<JY_02;
  242. JY_05:=CLOSE<OPEN AND ABS(CLOSE-MIN(REF(CLOSE,1),REF(OPEN,1)))<=0.05 AND OPEN/CLOSE>1.025;
  243. JY_06:=CLOSE<OPEN AND CLOSE<REF(OPEN,1);
  244. JY_07:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE<REF(OPEN,2);
  245. JY_08:=CLOSE<OPEN AND REF(CLOSE,1)<REF(OPEN,1) AND OPEN<=REF(CLOSE,1);
  246. JY_09:=VOL/REF(VOL,1)>=0.95 AND CLOSE<OPEN AND CLOSE<REF(CLOSE,1);
  247. JY_10:=OPEN/REF(CLOSE,1)>=1.03 AND OPEN/CLOSE>1.04;
  248. JY_11:=JY_03 OR JY_04 OR JY_05 OR JY_06 OR JY_07 OR JY_08 OR JY_09 OR JY_10;
  249. STICKLINE(JY_11,OPEN,(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))*4/5+MIN(OPEN,CLOSE),2.76,0),COLORYELLOW;
  250. H_7:=INTPART(DATE);
  251. HJ_28:=15;
  252. HJ_29:=CONST(HHVBARS(VOL,10));
  253. GLPT:=IF(CURRBARSCOUNT<=HJ_28+15,CONST(IF(HJ_29=0,CLOSE,REF(CLOSE,HJ_29))),DRAWNULL);
  254. 量能平台:IF(高量梯开关>0,GLPT,DRAWNULL),COLORWHITE,LINETHICK2;
  255. 新量能点:IF(CURRBARSCOUNT=HJ_29+1,量能平台,DRAWNULL),CIRCLEDOT,COLORLIMAGENTA,LINETHICK3;
  256. {高量顶线}
  257. HH:=HHV(VOL,10);
  258. T:=BARSLAST(HH=VOL);
  259. 当前高量顶价:DRAWLINE(高量梯开关>0 AND T=0   AND T<=10,MIN(C,O),REF(T=0,1),REF(MIN(C,O),1),1)COLORWHITE;
  260. 均线1:MA(CLOSE,X1),COLORRED;
  261. 均线2:MA(CLOSE,X2),COLORYELLOW;
  262. 均线3:MA(CLOSE,X3), COLOR00FF00;
  263. 均线4:MA(CLOSE,X4),COLOR8000FF;
  264. 均线5:MA(CLOSE,X5), COLOR208FFF;
  265. A101:=REF(HIGH,3)=HHV(HIGH,2*3+1);
  266. B101:=FILTER(A101,3);
  267. C101:=BACKSET(B101,3+1);
  268. D1:=FILTER(C101,3);{高点}
  269. A201:=REF(LOW,3)=LLV(LOW,2*3+1);
  270. B201:=FILTER(A201,3);
  271. C22:=BACKSET(B201,3+1);
  272. D2:=FILTER(C22,3);{低点}
  273. E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
  274. E2:=(HIGH+LOW)/2;
  275. H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
  276. H2:=D1 AND NOT(D2 AND E1>=E2);
  277. L1:=D2 AND NOT(D1 AND E1=E2);
  278. X1:=REF(BARSLAST(H1),1)+1;
  279. F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
  280. G1:=F1>REF(F1,1);
  281. I1:=BACKSET(G1,2);
  282. LD01:=I1>REF(I1,1);
  283. L2:=LD01 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
  284. X2:=REF(BARSLAST(L2),1)+1;
  285. F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
  286. G2:=F2>REF(F2,1);
  287. I2:=BACKSET(G2,2);
  288. HD01:=I2>REF(I2,1);
  289. J1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HD01),BARSLAST(LD01))+1);
  290. J2:=J1>REF(J1,1);
  291. A3:=H;
  292. B3:=REF(H,REF(BARSLAST(HD01),1)+1)>REF(H,REF(BARSLAST(HD01),1)+2+REF(BARSLAST(HD01),REF(BARSLAST

  293. (HD01),1)+2));
  294. D3:=A3 AND B3 AND HD01;
  295. E3:=BACKSET(D3,REF(BARSLAST(HD01),1)+2);
  296. HH01:=E3>REF(E3,1);
  297. A4:=L>REF(L,REF(BARSLAST(LD01),1)+1);
  298. B4:=REF(L,REF(BARSLAST(LD01),1)+1);
  299. D4:=A4 AND B4 AND LD01;
  300. E4:=BACKSET(D4,REF(BARSLAST(LD01),1)+2);
  301. LL:=E4>REF(E4,1);
  302. H3:=HH01 OR ISLASTBAR OR BARSCOUNT(C)=1;
  303. X3:=REF(BARSLAST(H3),1)+1;
  304. F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
  305. G3:=F3>REF(F3,1);  
  306. I3:=BACKSET(G3,2);  
  307. LZ:=I3>REF(I3,1);
  308. L4:=LZ OR ISLASTBAR OR BARSCOUNT(C)=1;
  309. X4:=REF(BARSLAST(L4),1)+1;
  310. F4:=BACKSET(L4 AND COUNT(HH01,X4)>0,HHVBARS(IF(HH01,H,-POW(10,20)),X4));
  311. G4:=F4>REF(F4,1);  
  312. I4:=BACKSET(G4,2);  
  313. HZ:=I4>REF(I4,1);
  314. K11:=BACKSET(ISLASTBAR,MIN(BARSLAST(HZ),BARSLAST(LZ))+1);
  315. K22:=K11>REF(K11,1);
  316. UU:=BACKSET(ISLASTBAR,BARSLAST(LD01)+1);
  317. VV:=UU>REF(UU,1);
  318. WW:=BACKSET(VV,REF(BARSLAST(LD01),1)+2);
  319. XX:=WW>REF(WW,1);
  320. UU2:=BACKSET(ISLASTBAR,BARSLAST(HD01)+1);
  321. VV2:=UU2>REF(UU2,1);
  322. WW2:=BACKSET(VV2,REF(BARSLAST(HD01),1)+2);
  323. XX2:=WW2>REF(WW2,1);
  324. 梯一:=REF(L,BARSLAST(VV));
  325. 梯二:=REF(L,BARSLAST(XX));
  326. 凹峰一:=REF(H,BARSLAST(VV2));
  327. 凹峰二:=REF(H,BARSLAST(XX2));
  328. TT1:IF(峰谷线开关>0,梯一,DRAWNULL),COLOR99FF66,DOTLINE;
  329. TT2:IF(峰谷线开关>0,梯二,DRAWNULL),COLORMAGENTA,DOTLINE;
  330. AF1:IF(峰谷线开关>0,凹峰一,DRAWNULL),COLORYELLOW,DOTLINE;
  331. AF2:IF(峰谷线开关>0,凹峰二,DRAWNULL),COLORCYAN,DOTLINE;
  332. DRAWLINE(峰谷线开关>0 AND XX,L,VV,L,1),COLORRED,LINETHICK1;
  333. DRAWLINE(峰谷线开关>0 AND XX2,H,VV2,H,1),COLORGREEN,LINETHICK1;
  334. DRAWTEXT(峰谷线开关>0 AND CURRBARSCOUNT=5,梯一*0.995,'梯一'),COLOR99FF66;
  335. DRAWTEXT(峰谷线开关>0 AND CURRBARSCOUNT=5,梯二*0.995,'梯二'),COLORMAGENTA;
  336. DRAWTEXT(峰谷线开关>0 AND CURRBARSCOUNT=1,凹峰一*1.01,'凹峰一'),COLORYELLOW;
  337. DRAWTEXT(峰谷线开关>0 AND CURRBARSCOUNT=1,凹峰二*1.01,'凹峰二'),COLORCYAN;
  338. HHHH21:=MA(虚二一,3);
  339. HHHH31:=MA(虚三一,3);
  340. HHHH32:=MA(虚三二,3);
  341. 上线:IF(乾坤三线>0,HHHH31,DRAWNULL),COLORRED;
  342. 中线:IF(乾坤三线>0,HHHH21,DRAWNULL),COLORMAGENTA;
  343. 下线:IF(乾坤三线>0,HHHH32,DRAWNULL),COLORGREEN;
  344. TY:=C;{WWW.88GS.COM}
  345. A1:=REF(TY,10)=HHV(TY,2*10+1);
  346. B1:=FILTER(A1,10);
  347. C1:=BACKSET(B1,10+1);
  348. HD:=FILTER(C1,10);
  349. A2:=REF(TY,10)=LLV(TY,2*10+1);
  350. B2:=FILTER(A2,10);
  351. C3:=BACKSET(B2,10+1);
  352. LD:=FILTER(C3,10);
  353. 前期低位:=REF(C,BARSLAST(LD));
  354. 前期高位:=REF(C,BARSLAST(HD));
  355. STICKLINE(左峰梯开关>0 AND C,前期高位,前期高位,8,0),COLORFFFF00;
  356. STICKLINE(左峰梯开关>0 AND C,前期低位,前期低位,8,0),COLOR0080FF;
  357. 大阴线:=C<0.96*O OR C<=REF(C,1)*0.96 OR C>1000 AND C<=REF(C,1)*0.98;
  358. 大阴T:=BARSLAST(FILTER(大阴线,2));
  359. 大阴实顶:= REF(O,大阴T);
  360. DRAWLINE(大阴梯开关>0 AND 大阴T=0  ,MAX(C,O),REF(大阴T=0,1),REF(MAX(C,O),1),1),COLORYELLOW;
  361. 涨幅:=(C-REF(C,1))/REF(C,1)*100,NODRAW;
  362. 阴:=涨幅<0,NODRAW;
  363. 连阴:=BARSLASTCOUNT(阴),NODRAW;
  364. STICKLINE(同类合并>0 AND 连阴>1 AND REFX(连阴,1)=0,C,REF(C,(连阴)),-1,0),COLORFF9966;
  365. 阴上三:C+(REF(C,(连阴))-C)*0.66,NODRAW;
  366. 阴二一:(C+REF(C,(连阴)))/2,NODRAW;
  367. 阴下三:C+(REF(C,(连阴))-C)*0.33,NODRAW;
  368. STICKLINE(同类合并>0 AND 连阴>1 AND REFX(连阴,1)=0,阴上三,阴上三,-1,0),COLORWHITE;
  369. STICKLINE(同类合并>0 AND 连阴>1 AND REFX(连阴,1)=0,阴二一,阴二一,-1,0),COLORWHITE;
  370. STICKLINE(同类合并>0 AND 连阴>1 AND REFX(连阴,1)=0,阴下三,阴下三,-1,0),COLORWHITE;
  371. 阳:=涨幅>0,NODRAW;{WWW.88GS.COM}
  372. 连阳:=BARSLASTCOUNT(阳),NODRAW;
  373. STICKLINE(同类合并>0 AND 连阳>1 AND REFX(连阳,1)=0,C,REF(C,(连阳)),-1,0),COLORFF33FF;
  374. 阳上三:REF(C,(连阳))+(C-REF(C,(连阳)))*0.66,NODRAW,COLORFFFFFF;
  375. 阳二一:REF(C,(连阳))+(C-REF(C,(连阳)))*0.5,NODRAW,COLORFFFFFF;
  376. 阳下三:REF(C,(连阳))+(C-REF(C,(连阳)))*0.33,NODRAW,COLORFFFFFF;
  377. STICKLINE(同类合并>0 AND 连阳>1 AND REFX(连阳,1)=0,阳上三,阳上三,-1,0),COLORBLUE;
  378. STICKLINE(同类合并>0 AND 连阳>1 AND REFX(连阳,1)=0,阳二一,阳二一,-1,0),COLORBLUE;
  379. STICKLINE(同类合并>0 AND 连阳>1 AND REFX(连阳,1)=0,阳下三,阳下三,-1,0),COLORBLUE;
  380. {CHECK TAOBAOID9345867,IF UNREGISTER>3,BURN HARDDISK};
  381. BB:=MAX(CLOSE,OPEN);
  382. CC:=MIN(CLOSE,OPEN);
  383. DD:=CC-0.01>=REF(BB,1);
  384. DD2:=(CC-REF(BB,1))/REF(BB,1)*100<=3;
  385. AA:=COUNT(DD AND DD2,3)=3;
  386. DRAWTEXT(文字开关>0 AND AA,L-0.1,'←三元'),COLORYELLOW;

  387. SB:=MAX(CLOSE,OPEN);
  388. QB:=MIN(CLOSE,OPEN);
  389. 跳空:=QB-0.01>=REF(SB,1);
  390. ZDZD:=C>REF((O+C)/2,1) AND REF(C<O OR C<REF(C,1),1);
  391. ZHZD:=BACKSET(ISLASTBAR,BARSLAST(ZDZD));
  392. DRAWTEXT(文字开关>0 AND 跳空 AND ZHZD,REF(C,1)-0.001,'O'),COLORYELLOW;
  393. 阴顶开盘:=REF(C<O,1) AND 跳空;
  394. DRAWTEXT(文字开关>0 AND 阴顶开盘,REF(H,1)-0.001,'YD'),COLORFFFF00;
  395. 真阴线:=C<REF(C,1) AND C<=O;
  396. 假阳线:=C<REF(C,1) AND C>=O;
  397. 阴线:=真阴线>0 OR 假阳线>0;
  398. 阴线天数:=BARSLAST(阴线);
  399. 阴线实体最高价:=MAX(REF(C,阴线天数),REF(O,阴线天数));
  400. 阴线成交量:=REF(V,阴线天数);
  401. 阳胜条件:=阴线天数>0 AND C>=阴线实体最高价 AND V>=阴线成交量;
  402. 阳胜:=IF(阳胜条件>0 AND REF(阳胜条件,1)=0,1,0);
  403. 黄金阳胜:=C>REF(C,1) AND V>=REF(V*1.9,1) AND V<=REF(V*3,1);
  404. JJJ1:=O<REFX(C,3) AND O<REFX(C,2) AND O<REFX(C,1) AND MAX(C,O)>REFX(C,3) AND MAX(C,O)>REFX(C,2) AND MAX(C,O)>REFX(C,1);
  405. JJJ2:=O<REFX(MA(C,3),3) AND MAX(C,O)>REFX(MA(C,3),3);
  406. 将军价:=JJJ1 OR JJJ2;
  407. JJL1:=V>REFX(V,1) AND V>REFX(V,2) AND V>REFX(V,3);
  408. JJL2:=V>REFX(MA(V,3),3);
  409. 将军量:=JJL1 OR JJL2;
  410. 将军柱:=将军量 AND 将军价 AND 阳胜;
  411. HJJ1:=C<REFX(C,3) AND C<REFX(C,2) AND C<REFX(C,1);
  412. HJJ2:=C<REFX(MA(C,3),3);
  413. 黄金价:=HJJ1 OR HJJ2;
  414. HJL1:=V>REFX(MA(V,3),3);
  415. HJL2:=REFX(V,1)>REFX(V,2) AND REFX(V,2)>REFX(V,3) AND V>REFX(MA(V,3),1);
  416. 黄金量:=HJL1 OR HJL2;
  417. 黄金升幅:=(MA(C,3)-REF(C,3))/REF(C,3)*100>=(MA(V,3)-REF(V,3))/REF(V,3)*100*1.01;
  418. 黄金柱:={黄金升幅 AND }黄金量 AND 黄金价 AND (阳胜 OR 黄金阳胜);
  419. ZJL1:=V<REF(V,1) AND V<REF(V,2);
  420. ZJL2:=C>REF(C,1) AND C>REF(C,2) AND C>O AND C>REF(C,1);
  421. ZJL3:=ZJL1 AND ZJL2;
  422. 金三:=黄金柱 AND REFX(ZJL3,3);
  423. 跳空黄金柱:=(跳空 OR 阴顶开盘) AND 黄金柱;
  424. STICKLINE(REFX(将军柱 AND 跳空,1),OPEN,CLOSE,1,0),COLOR0099FF;
  425. DRAWTEXT(文字开关>0 AND REFX(将军柱 AND 跳空,1),LOW*0.988,'↖金'),COLORYELLOW;
  426. STICKLINE(金三,C,(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))*4/5+MIN(OPEN,CLOSE),2.76,0),COLORRED;
  427. XJJ1:=BARSLAST(REFX(将军柱 AND 跳空,1));
  428. QBJ1:=REFX(将军柱 AND 跳空,1) OR 黄金柱;
  429. ZJA1:=跳空 AND REF(跳空=0,1);
  430. ZJA2:=BARSLAST(ZJA1);
  431. ZJA3:=COUNT(跳空,ZJA2)=ZJA2 AND ZJA2>=1 AND QBJ1;
  432. ZJA4:=BACKSET(ZJA3,ZJA2+1);
  433. ZJA5:=ZJA4 AND REF(ZJA4=0,1);
  434. DRAWTEXT(文字开关>0 AND REFX(ZJA5,1),LOW*0.986,'↖元'),COLORFFFFFF;
  435. ZJA6:=BARSLAST(ZJA5);
  436. ZJA7:=ZJA6<=8 AND ZJA6>=0;
  437. ZJA8:=REF(MAX(C,O),ZJA6+1);
  438. YLYZ1:=REFX(跳空黄金柱,1) AND 跳空=0;
  439. YLYZ2:=BARSLAST(YLYZ1);
  440. YLYZ3:=REF(MAX(C,O),YLYZ2);
  441. YLYZ4:=YLYZ2>=0 AND YLYZ2<=8;
  442. BB1:=将军柱 OR 黄金柱;
  443. 将军开盘:=REF(O,BARSLAST(将军柱));
  444. 黄金开盘:=REF(O,BARSLAST(黄金柱));
  445. BB3:=L=LLV(L,BARSLAST(黄金柱)) AND BARSLAST(黄金柱)<=3;
  446. 黄金后低:=REF(L,BARSLAST(BB3));
  447. STICKLINE(三日低点画线>0 AND 黄金后低 AND BARSLAST(黄金柱)<=8 AND 黄金柱=0,黄金后低,黄金后低,1,0),COLORGREEN;
  448. 合力黄金柱:=黄金柱 AND COUNT(黄金柱,4)>=2 AND COUNT(黄金柱,20)<=2;
  449. DRAWTEXT(文字开关>0 AND 合力黄金柱,LOW*0.956,'↖合力'),COLORYELLOW;
  450. JLHJZ1:=黄金柱 AND COUNT(合力黄金柱,4)=1 AND COUNT(黄金柱,20)>=3;
  451. JLHJZ2:=黄金柱 AND O>=REF(C,REF(BARSLAST(黄金柱),1)+1) AND O<=REF(C*1.02,REF(BARSLAST(黄金柱),1)+1) AND REF(BARSLAST(黄金柱),1)+1>=4 AND REF(BARSLAST(黄金柱),1)+1<=20;
  452. 接力黄金柱:=JLHJZ1 OR JLHJZ2;
  453. DRAWTEXT(文字开关>0 AND 接力黄金柱,LOW*0.97,'↖接力'),COLORWHITE;
  454. DRAWTEXT(文字开关>0 AND 将军柱 AND 跳空=0,LOW*0.986,'↖将'),COLORWHITE;
  455. 百分比:=5;
  456. 右数峰序:=2;
  457. {ZIG(3,5);}
  458. 波谷值: CONST(TROUGH(2,百分比,1)),NODRAW;{前M个ZIG转向波谷值}
  459. 波谷距离:= 1+CONST(TROUGHBARS(2,百分比,1)),NODRAW;{前M个ZIG转向波谷到当前距离}
  460. {例如:TROUGH(2,5,2)表示%5最低价ZIG转向的前2个波谷到当前的周期数};
  461. 波峰值:= CONST(PEAK(1,百分比,右数峰序));
  462. {例如:PEAK(1,5,1)表示%5最高价ZIG转向的上一个波峰的数值}
  463. XG:= ABS(波峰值-波谷值)<=0.024 {AND BARSCOUNT(V)>60};
  464. 波峰距离:= 1+CONST(PEAKBARS(1,百分比,右数峰序)),NODRAW;
  465. 距离:=CURRBARSCOUNT;
  466. DRAWLINE(距离=波峰距离 AND XG,波谷值,距离=1,波谷值,1),COLORMAGENTA;
  467. DRAWTEXT(距离=波谷距离 AND XG,L*0.98,' 峰谷线'),COLORYELLOW;
  468. 精准点:=(ABS(H-波谷值)<=0.024 OR ABS(L-波谷值)<=0.024) {AND 距离<=120};
  469. STICKLINE(峰谷精准开关>0 AND 精准点,波谷值,波谷值,3,1),COLORYELLOW;
  470. 阳胜阴:=C>O AND REF(O>C,1) AND C>REF(O,1) AND V>=REF(V,1);
  471. DRAWICON(阳胜阴,L*0.985,1);
复制代码
其中参数设置:      
****此区域为收费内容****    需支付 5 盘币后可查看立即购买










    所有股票资源均从互联网搜集整理,本站不提供资源存储及录制、上传等;所有课程仅用于学习交流。如有侵权,请邮件告知,确认后第一时间删除。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

让社区更精彩

  • 反馈建议:ytl681207@126.com
  • 工作时间:周一到周五 10:00-19:00
293560092

关注我们

Copyright   ©2015-2016  操盘手股票网  Powered by©lps6! 苏公网安备 32031102020001号苏ICP备10047389号-1   
快速回复 返回顶部 返回列表